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Unable to find Advantage service or bindery on the network (HW163)

(6420 Error on Windows 2000 Machine that is NOT Connected to a Network)

DESCRIPTION:

After installing the Advantage Database Server (ADS) for Windows NT/2000 on a Windows 2000 Server or Professional machine, you might receive a "Bindery"  or 6420  "Unable to Find Advantage" error.

CAUSE:

This error message is generally generated by a network communication error.  If the system is connected to a network please SEE OTHER POSSIBLE CAUSES below.

 

SOLUTION:

 

This scenario only applies if the system is not connected to a network. Windows 2000 uses media-sense which detects if the Network Interface Card (NIC) is connected to the network. If the NIC is not connected to the network Windows 2000 disables the protocols on that adapter. Since ADS requires networking protocols to function correctly this will cause an error.

There are two solutions to this problem.

1) Microsoft provides a LOOPBACK adapter (
Article ID: Q236869) that will resolve this issue. Simply install the Microsoft Loopback Adapter and disable the other Network Adapter when you are disconnected from a network.

2) You can disable the media-sense for TCP/IP protocol using the following steps:

1.. Start the registry editor (regedit.exe)
2.. Move to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
3.. From the Edit menu select New - DWORD value
4.. Enter a name of DisableDHCPMediaSense and press Enter
5.. Double click the new value and set to 1
6.. Click OK
7.. Reboot the computer

OTHER POSSIBLE CAUSES: (when the system is connected to a network)

bullet

Stop the Advantage service and restart it in the services. (please note, all stations must exit the software before stopping the ADS service.)

bullet

TCP/IP is not listed first in the binding order. (See advanced network properties of the local area connection in my network places properties of 2000 or binding order in WINNT 4.0.)

bullet

Client is running Windows 98 as the workstation and is using IPX/SPX protocol and TCP/IP.  IPX should be removed from the list of protocols installed so it does not appear in the binding order of the 98 workstations.  (It is acceptable to leave IPX on the 2000 Server as long as the binding order is correct.)

bullet

Server needs to have IPX loaded.  Add IPX protocol to the server and make sure that TCP/IP is still listed first in the binding order, reboot the server and test the software.  (Note: in certain instances, IPX might also need to be added to the workstations, make sure TCP/IP is listed first in the binding order on the workstation also.)

bullet

Client in running TCP/IP protocol.  All computers are using static IPs, the computer that is dynamic will receive the Bindery message.  Check TCP/IP settings on all computers and make sure they are all either static or dynamic.

bullet

Client has NETBEUI protocol installed, remove NETBEUI from the installed protocol list.

bullet

There are two Local Area Connections, the one that is not used needs to be disabled or use the ADS.INI file to bypass discovery.

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In some cases the client will also experience slow performance.  Contact the hardware department for bypassing the discovery process for ADS service and  installing ADS.INI and new DLLs.

bullet

Be sure the mapped drive is correct and using the UNC with the server name and not the IP address. In case client would like to use IP when mapping, add a second entry in the ADS.INI with the IP address instead of the computer name.

 

 BY: MRA - 04/2004

    


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Last modified: 05/14/12.